PixPlant Help

1. About PixPlant

PixPlant creates and edits textures and 3D maps for texturing and modeling. Includes everything needed to transform a common photo into seamlessly tiling 3D maps: diffuse, displacement, normal, specular and ambient occlusion.
Besides the image-to-3D maps workflow, PixPlant can be used to synthesize tiling versions of images or to edit 3D maps created with other applications. With the included 3D Preview you can immediately see how the maps will look applied in a model.

The third major version of PixPlant includes many improvements over previous versions based on all the kind user feedback we've received:

2. Interface

PixPlant interface is divided in two main areas, the Texture and 3D Maps areas which can be selected by clicking the Texture or 3D Maps tabs lined vertically at the left side of the interface - please see the screenshot image below.
This separation between Texture and 3D Maps reflects the two logical steps in an image-to-3D workflow: first obtain a good tiling texture, then produce and edit 3D maps from it. Of course you can also separately use PixPlant for generating tiling textures or create and edit 3D maps.

Information button Larger editing areas always have an information icon at their left-bottom corner which you can click for an explanation tooltip - they look like this:

Most of user interface elements have tooltips with the title and sometimes a description of the functionality - simply hover the mouse cursor over the element to find out.

As a general rule, clicking on the label of an interface element will reset its value to a default value. Where this doesn't happen you will find and explicit Reset option. For example clicking in the Width or Height slider labels of the Texture Area screenshot below will set their values to 100% (or the nearest possible seed scale if Snap Scale is checked)

3. Generating Textures

Tiling textures are generated in the Texture Area, by selecting the Texture tab at the left:

Texture Area Texture Area

The main left area displays the generated or loaded image, while the right side contains texture synthesis tools in the Texture Synth area. To generate a tiling texture you first load an image to be used as seed image, if needed prepare it with the Seed Wizard and then generate till you obtain a satisfying texture. You can also partially generate into sections of the texture. After you're satisfied with the texture you can send it to the 3D Maps area by clicking on the Extract 3D Maps button above the texture area.

For more information, see the Texture Area Help.

4. Creating and Editing 3D Maps

By selecting the 3D Maps tab at the left you enter the 3D Maps Area:

3D Maps Area 3D Maps Area

The main area at the left is the 3D Preview which displays the edited maps applied to a 3D model. In the right side are the map editors for Diffuse, Displacement, Normal, Specular and Ambient Occlusion. For each of these areas the layout is similar: at the left is the map editor, to the right the editing tools. Also in any of these areas you can open, save, copy, paste new and have undo-redo functionality.

The editing tools come in two types: image-level and pixel-level tools. Image-level tools allow you modify the whole image/surface – allowing for example equalization of the image at different scales; while pixel-level tools edit at pixel level – they are the tools you know from image editors or 3D sculpting applications.
The underlying idea is that you can use the image-level tools to manipulate the whole image/surface and then change small details with the pixel-level tools.

For more information, see the 3D Maps Area Help.

5. View Control

All the viewers and editors in both the Texture and 3D Maps areas share common view control functionality:

6. External Edit

External edit button

The editors in all areas include the capability to transfer edition of the image into an external application and import it back as soon as it is saved from the other application. This is done on any open map with the External Edit button:

The external application can be defined in the Preferences or it will be asked the first time you use this feature.

7. PixPlant Projects

PixPlant allows you to edit individual maps or textures, but more useful for continued development is the ability to keep several 3D maps grouped so that work can later proceed on them. This is implemented in PixPlant in the form of projects. After creating a project any files that you edit will be kept together and opened when you open the project.

You can create either an empty project or one with whichever maps are open at the time and it will later open those maps each time you open the project file from the File menu or by directly opening the project file with .pixplant extension in the File Explorer/Finder.

There is no explicit "Save Project" option because projects are saved when needed – it happens automatically.
Besides the project file itself being automatically saved there is a setting in the preferences which is enabled by default that causes new maps in a project and maps with unsaved changes to be automatically saved when needed. We recommend this setting to be left enabled to avoid the hassle of being prompted to save individual maps when you work in projects.

Take care that image maps included in a project are saved as separate ordinary image files so they should be kept in the same or a relative folder to the project file. If you move the project, make sure to move the included images together with it.

PixPlant project files are stored with the .pixplant extension.

8. Common Actions

Common Actions dialog PixPlant presents the most commonly used editing actions in a single window, displayed when you start PixPlant or at any other time by selecting Window > Common Actions.

Any action of the Common Actions window can of course be executed on its own - this is a way of concentrating common workflow actions in a single window.

9. Photoshop Plug-In

PixPlant includes a plug-in for 64-bit Adobe Photoshop or other compatible 64-bit hosts. Photoshop CS6, CC and higher are supported. (CS 5 and previous versions of Photoshop should also work but they have not been tested).
The plug-in supports RGB and grayscale images in 8-bit, 16-bit and 32-bits per channel.

Installing

Plug-in selection dialog

The Windows installer already searches for Photoshop installations (of known versions) and copies the plug-in to the right locations. To install manually, simply go to the PixPlant installation folder and copy PixPlant3.8bf into the Plug-ins/ folder of your Photoshop installation - make sure you're copying into a 64-bits version of Photoshop as the plug-in is 64-bit only.

In Mac OS X, open the installation DMG file and drag and drop the plug-in file into the Plug-ins/ folder inside the Photoshop installation (usually located inside /Applications).

How It Works

The PixPlant plug-in works like any other Photoshop plug-in, available from the Filter menu of Photoshop. When invoked, PixPlant runs in plug-in mode, allowing you to edit the image in any of PixPlant's editors: this can be chosen from the selection dialog (at right) which appears.

To return back to Photoshop (or other plug-in host), simply Quit or close PixPlant's main window. Since Photoshop only allows plug-ins to return a single image, any other images that you edit in PixPlant will need to be saved: before returning to Photoshop, PixPlant will offer to save any unsaved work.

© PixPlant/FaronStudio · All trademarks are the property of their respective owners · Photos by Ben Cloward